Platform Access & API Degradation

Incident Report for emailverify

Resolved

The issue impacting API performance and dashboard access has now been fully resolved.

To ensure long-term platform stability and prevent similar disruptions, we have implemented a rate limit of 5 requests per second per API key. Requests exceeding this limit may receive a rate limit response.

We recommend adjusting your integration to respect this threshold to avoid timeouts or temporary blocks.

Thank you for your patience and continued trust. If you experience any further issues, please don’t hesitate to contact us.
Posted Feb 20, 2026 - 15:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2026 - 10:08 UTC

Identified

We are currently experiencing issues impacting dashboard access and API performance. Some users may face timeouts, slow loading times, or failed requests.

Our technical team is actively investigating the cause and implementing corrective measures to restore full service stability.

We sincerely apologize for the disruption and appreciate your patience. Further updates will be shared here shortly.
Posted Feb 20, 2026 - 07:50 UTC
This incident affected: API, Management Portal (example), and App.